1 (edited by lifesaver 2014-08-24 13:26:12)

Topic: Epic not installed properly in Turkish Windows?

I've tried installing Epic on my primary 64-bit Windows 8.1 PC and 32-bit Windows 7 (virtual PC), but both didn't work properly.

I'm guessing there should be a few extensions installed by default and listed in chrome://extensions/ , but that page is blank.

Obviously, I don't see any additional buttons on the interface, some promised functions don't work and nowhere to be seen, and looks exactly like a Chromium interface without notifications.

What could be causing this? Any suggestions?

Re: Epic not installed properly in Turkish Windows?

Hi lifesaver,

Thanks for writing us.

Chrome's web store extensions are not supported in Epic.

We have our own web store , you can get few of the verified extensions from https://epicbrowser.com/webstore .

Extensions installed from our web store are listed in chrome://extensions page.

We have disabled few of the chromium's features in Epic to protect user's privacy.

Re: Epic not installed properly in Turkish Windows?

Thanks, sathi, but I think you misunderstood the question.

Here's what Epic looks like on my system: http://min.us/i/nhujF4IRWK6i

Does this look right to you?

Re: Epic not installed properly in Turkish Windows?

Hi Lifesaver,

It's not happening for me in Turkish, but I will check into this.
Did you try  re install the browser again  or deleting the browser app data?

Re: Epic not installed properly in Turkish Windows?

sathi wrote:

Hi Lifesaver,

It's not happening for me in Turkish, but I will check into this.
Did you try  re install the browser again  or deleting the browser app data?

I've tried both, but they didn't help.