Announcement

We're EpicBrowser on Twitter and on Facebook. Email our Founder directly with questions as well: alok at hiddenreflex dot com
New Users: we've had to temporarily block new registrations due to spam. If you have a post or query, email it to Alok and he'll try to help you and or post it to the forum.

#1 2017-04-17 00:13:44

inheral
Guest

Epic Will Not Close

Epic used to be great but now will not close when i press X on the top right corner. It just greys out and won't close so i have to force close it with task manager. This browser has many bugs and is not functioning properly.

Offline

#2 2017-04-28 02:28:27

alok_epicteam
Administrator

Re: Epic Will Not Close

Sorry, we think something in a Windows 10 update has screwed up Epic at close...we're not sure what.  An update is coming out in a few weeks in late May which should solve this.  Sorry about the annoyance in the meantime, thanks as always for your support!

Offline

#3 2017-05-07 07:19:43

Re: Epic Will Not Close

This simple trick helped me and I have done this on Epic Browser and Comodo Drogon (Chrome Browser)

Menu, Settings, Show Advanced Settings, System
-->Disable "Use hardware acceleration"

More Help can be found here:
http://www.stcleaner.com/blog/2016/03/2 … indows-10/

Offline

#4 2017-05-14 09:19:40

id1crypt
Guest

Re: Epic Will Not Close

Alexander_Noitahl wrote:

This simple trick helped me and I have done this on Epic Browser and Comodo Drogon (Chrome Browser)

Menu, Settings, Show Advanced Settings, System
-->Disable "Use hardware acceleration"

More Help can be found here:
http://www.stcleaner.com/blog/2016/03/2 … indows-10/

It works!
Now it is possible to exit Epic Browser correctly with several open tabs and it is possible to save passwords.
Thank you very much!

Offline

#5 2017-05-21 18:59:03

inheral
Guest

Re: Epic Will Not Close

Disabling hardware acceleration worked. Thank You.

Offline

#6 2017-05-25 02:51:14

alok_epicteam
Administrator

Re: Epic Will Not Close

Yes, we were finally able to reproduce this issue on a Win10 machine (still doesn't happen on most Win10 machines) and disabling hardware acceleration at the bottom of the settings page worked.

Brilliant find Alexander!!!  Great work!

Offline

Board footer