Announcement

Epic for iOS and Android are live in the App Store and the Android Play Store. We're EpicBrowser on Twitter and on Facebook. Please feel free to also email our Founder directly with issues or questions: alok at hiddenreflex dot com

#1 2021-09-15 05:21:14

ebeb
Guest

CloudFlare DDoS Protection Fails to Execute, Infinite Loop

Some sites that use Cloudflares DDoS Protection don't seem to work with Epic Browser. When you load the page, you see the cloudflare DDoS protection page, then the page refreshes, then you see the cloudflare DDoS page again. This loops forever.

If you open developer tools you'll see the initial request to the page returns a server 503 with the page rendering a "please enable javascript and reload the page" message from cloudflare.

This is with a fresh install of the browser, and happens with all plugins disabled or enabled and turned off. Connected to the proxy/vpn or not. adblock turned on or not. I've made sure javascript is enabled too. Nothing works.

Someone else reported the same problem accessing a site here that also uses Cloudflare DDoS protection: https://forum.epicbrowser.com/viewtopic.php?id=58931

Even with everything disabled (proxy/vpn, adblock, etc.) it still doesn't load. What is Epic Browser doing that is interfering with the javsacript cloudflare wants to run if I have everything disabled?

Offline

#2 2022-05-22 12:27:09

Proxy1
Administrator

Re: CloudFlare DDoS Protection Fails to Execute, Infinite Loop

I contacted Alok for some info.

Macs work fine, Intel and M1. I have disabled Cloudflare on occasion for some sites not wishing to troubleshoot but it's rare.

Offline

#3 2022-06-02 02:41:18

Proxy1
Administrator

Re: CloudFlare DDoS Protection Fails to Execute, Infinite Loop

You are correct, it's complicated by a variety of factors to numerous to mention. I don't have the answers except that it works well most of the time with macOS.......

Offline

Board footer